16 diciembre 2006

Soporte multimedia en openSUSE 10.2: KonvenientSuse


KonvenientSUSE es la manera más cómoda de añadir soporte multimedia (escuchar mp3, ver películas), instalar java o añadir los controladores de nvidia que soportan aceleración 3D en openSUSE 10.2. Es el equivalente a Automatix en Ubuntu o Fedora Frog para Fedora.

Es un script desarrollado con Kommander por lo que será necesario que instalemos desde Yast el rpm necesario para que funcione. Tan fácil como abrir el instalador de software en Yast, buscar el paqute kommander-runtime e instalarlo desde nuestros cds o dvds.

Ahora ya podemos descargar la última versión de KonvenientSUSE desde kde-apps.org: http://www.kde-apps.org/content/show.php?content=43378.
Una vez descarguemos e instalemos el .rpm (basta con hacer clic sobre él y se lanzará el proceso de instalación) tendremos disponible KonvenientSUSE en el menú "Sistema->Configuración".

Lo primero a tener en cuenta es el tipo de software de manejo de paquetes que vamos a emplear. openSUSE 10.2 usa por defecto Zenworks pero lo más recomendable (por rendimiento y calidad) es usar el sistema openSUSE. KonvenientSUSE tiene soporte para Zenworks, openSUSE y Smart e incorpora una opción para eliminar Zenworks e instalar el software de paquetes de openSUSE. Independientemente de que usemos el sistema de manejo de paquetes de Zenworks u openSUSE, los repositorios que añadamos estarán disponibles desde Yast.

Escogido el sistema de paquetes deseado, procederemos a añadir los repositorios que deseemos. KonvenientSUSE explica detalladamente para que sirve cada uno, así que no tendremos problemas para añadir los que más nos interesen. Tan sólo nos queda ir a la pestaña "Multimedia" e instalar lo que queramos: soporte para ver dvds, escuchar mp3, ver todo tipo de formatos de video, instalar java o el plugin para ver animaciones flash. Si queremos instalar los controladores de Nvidia bastará con ir a la pestaña "Nvidia" y seguir las instrucciones para descargar e instalar los controladores que correspondan con nuestra versión del kernel instalada en ese momento.

Lo único que malo es que está disponible únicamente en inglés, pero es bastante probable que podamos disfrutar dentro de poco tiempo de una versión en castellano.

11 comentarios:

hurior dijo...

¿Funciona con SuSE 10.0?

Raúl Moratalla dijo...

Hola, no que yo sepa. Hay una versión (discontinuada) para Suse 10.1 pero para la 10.0 no hay nada :(

Luis dijo...

Saludos desde Chile...

Hace poco boté mi ubuntu edgy debido a que he tenido muchos problemas con el gravador DVD, los discos son estropeados por el gravador en la instancia de la creación del ISO, en fin... Pasé por varias distribuciones y me quedé en Opensuse para ver qué tal es, pero he tenido varios problemas con las configuraciones de paquetes, en Ubuntu no cuesta nada agregar un un repositorio al sourcelist, pero acá veo que no es tan fácil y al parecer es más lento. Para empezar instalé Konvenient buscando un reemplazo para el automatix, pero no entiendo bien cómo funciona, sería mucho pedir que agregues algunnos SS para ver cómo lo configuras?
GRACIAS

luchifer

Raúl Moratalla dijo...

KonvenientSuse es suficientemente autoexplicativo, hay que limitarse a seleccionar donde quieres añadir los fuentes y luego seleccionas los repositorios que quieres. Se incluye una descripción sobre que contiene cada repositorio.

Luego podrás instalar paquetes, bien desde yast o desde smart. Lo normal es hacerlo en yast, los más acostumbrados a synaptic prefieren smart (que lo incluye suse en los cds o dvd).
Tal vez estos enlaces te sean de utilidad:
http://en.opensuse.org/Add_Package_Repositories_to_YaST
http://en.opensuse.org/Additional_YaST_Package_Repositories
http://susewiki.org/index.php?title=SMART_Package_Manager
http://wiki.suselinuxsupport.de/wikka.php?wakka=HowtoSmartPackageManager

Luis dijo...

ok, lo voy a probar... Acabo de terminar el primer update que hago en opensuse, estuve toda la tarde, es idea mías o es más lento para estos procesos de Ubuntu?

Otra consulta, abusando de tu amabilidad, cómo instalo los codecs para dvd? traté de ver un DVd en Kaffeine y la venta de bienvenida me avisó que faltan todos los codecs...

luchifer dijo...
Este comentario ha sido eliminado por el autor.
luchifer dijo...

Finalmente pude actualizar desde Yast, agregué los repositorios multimedia y cargué los codecs, tuve algunos problemas con ciertos .rpm que no se encontraban en los repositorios, pero los bajé de la red y creé una carpeta 'packages' la cual a su vez incluí en la lista de fuentes, con esto logré, depsués casi todauna tarde, actualizar Opensuse 10.2 y finalmente ver un DVD... Hoy tratré de probar como reproduce mp3 y m4a...
Gracias por tu ayuda.

Raúl Moratalla dijo...

Hola Luis, antes de nada decir que esta entrada del blog era más informativa que una guía sobre como instalar todo el soporte multimedia. Pero visto lo visto será interesante hacer una nueva entrada que sirva como guía :)

Respecto a la velocidad de actualización, los servidores de Ubuntu suelen ir muy rápidos, los de OpenSUSE no tanto.

Para ver dvds necesitas instalar el fichero libdvdcss. Esta es su url:
http://download.videolan.org/pub/videolan/vlc/SuSE/10.2/i586/libdvdcss-1.2.9-2.0.i586.rpm

De todas formas VLC es un buen reproductor multimedia. Si te interesa puedes añadir su repositorio. En esta dirección explican cómo hacerlo:
http://www.videolan.org/vlc/download-suse.html

Espero que sea de ayuda.

luchifer dijo...

Disuclpa si no entendì la naturleza del blog, por lo general los glogers que postean sobre temas de linux lo ahcen con el ánimo de abrir un pequeño devate y ayuda sobre un tema, de todas maneras gracias por la ayuda ayer tuve tiempo para dedicarle a opensuse y ya estoy en camino para seguir configurándolo en loq ue neceisto así que también abrí mi blog para esos fines... Ahora seguiré en los archivos de música y la sincronización del ipod, auqnue ya había probado amarok en ubuntu y funcionaba de pelos.

Gracias!!!

Raúl Moratalla dijo...

Luis, no te decía nada a malas, sino que me ha pillado de improvisto que sobre este tema surgiera este debate, cuando en realidad hice este artículo un día porque había salido konvenientsuse jeje

luchifer dijo...

No te preocupes si entendí super bien... De todas maneras me ayudaste a entender un poco más, como te contaba yo estuve buscando un reemplazo para el automatix en suse y en Google lo primero que encontré fue el link de tu blogg.

Ayer realicé otra actualización y puse a prueba el K3B para ver el problema de las copias y hasta le moemnto ha funcionado incluso mejor que Ubuntu, en la mañana cargué y actualicé mi ipod shuffle y pasó sin problemas, así que creo que tengo nuevo OS

PD: disculpa las faltas de ortografía y las letras dadas palabras mal escritas, pero es que posteo desde mi trabajo y siempre preocupado de que no me vean...